fa.netbsd.bugs
[Top] [All Lists]

kern/39594: acroread8 doesn't work in linux32 emulation

Subject: kern/39594: acroread8 doesn't work in linux32 emulation
From: Thomas Klausner
Date: Sun, 21 Sep 2008 17:05:09 UTC
Newsgroups: fa.netbsd.bugs

>Number:         39594
>Category:       kern
>Synopsis:       acroread8 doesn't work in linux32 emulation
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 21 17:05:00 +0000 2008
>Originator:     Thomas Klausner
>Release:        NetBSD 4.99.72
>Organization:
>Environment:
        
        
Architecture: x86_64
Machine: amd64
>Description:
print/acroread8 doesn't work in linux32 emulation on amd64.
When starting it, the error message is:
cannot set up thread-local storage: cannot set up LDT for thread-local storage

Nicolas Joly says that it needs the modify_ldt(2) syscall, but that
depends on the USER_LDT kernel option, which NetBSD/amd64 currently
doesn't support.
>How-To-Repeat:
cd /usr/pkgsrc/print/acroread8
make install
acroread8
>Fix:
Probably: Implement modify_ldt(2) for linux32 emulation.

>Unformatted:
        
        

<Prev in Thread] Current Thread [Next in Thread>
  • kern/39594: acroread8 doesn't work in linux32 emulation, Thomas Klausner <=