[email protected]
[Top] [All Lists]

Re: [Ekiga-list] Error message when exiting ekiga.

Subject: Re: [Ekiga-list] Error message when exiting ekiga.
From: Damien Sandras
Date: Wed, 31 Dec 2008 14:52:48 +0100
Le mercredi 31 dÃcembre 2008 Ã 14:24 +0100, Stefan Lucke a Ãcrit :
> On Wednesday 31 December 2008, Eugen Dedu wrote:
> > Stefan Lucke wrote:
> > > On Wednesday 31 December 2008, Damien Sandras wrote:
> > >> Le mercredi 31 dÃcembre 2008 Ã 09:48 +0100, Stefan Lucke a Ãcrit :
> > >>> Hi,
> > >>>
> > >>> I get the following error message upon exiting ekiga:
> > >>>
> > >>> [email protected] ~ $ date;ekiga;date
> > >>> Mi 31. Dez 09:46:28 CET 2008
> > >>>       assert.cxx(108)   PWLib   Assertion fail: Function 
> > >>> pthread_mutex_lock failed, file ptlib/unix/tlibthrd.cxx, line 1304
> > >>> Assertion fail: Function pthread_mutex_lock failed, file 
> > >>> ptlib/unix/tlibthrd.cxx, line 1304
> > >>>
> > >>> <A>bort, <C>ore dump? A
> > >>>
> > >>> Aborting.
> > >>> Mi 31. Dez 09:46:41 CET 2008
> > >>>
> > >>> I'm using svn checkout of ekiga from 2008-12-29.
> > >>> Should I provide a dump or some other debug information or report this 
> > >>> problem elsewhere?
> > >>
> > >> A full GDB backtrace (see the wiki for more details on
> > >> http://wiki.ekiga.org).
> > > 
> > > ptlib cannot be build with: 'make DEBUG=1 debug' and thus opal cannot
> > > be confgured with --enable-debug when ptlib is build without DEBUG=1.
> > > 
> > > cxx -o 
> > > /home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/lib_linux_x86/obj_d/tinyjpeg.o
> > > g++ -DPTRACING=1 -D_REENTRANT    -D_GNU_SOURCE=1 -D_REENTRANT 
> > > -I/usr/include/SDL    -fno-exceptions  -Wall  -fPIC -DPIC -g3 -ggdb -O0 
> > > -D_DEBUG -I/home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/include 
> > >  -felide-constructors -Wreorder  -c ptlib/common/jidctflt.cxx -o 
> > > /home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/lib_linux_x86/obj_d/jidctflt.o
> > > /tmp/ccJhh47h.s: Assembler messages:
> > > /tmp/ccJhh47h.s:1101: Error: suffix or operands invalid for `sar'
> > > make[2]: *** 
> > > [/home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/lib_linux_x86/obj_d/jidctflt.o]
> > >  Fehler 1
> > > make[2]: Leaving directory 
> > > `/home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/src'
> > > make[1]: *** [debug] Fehler 2
> > > make[1]: Leaving directory 
> > > `/home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29/ptlib/src'
> > > make: *** [debug] Fehler 2
> > 
> > Hi,
> > 
> > Do you use gcc or other compiler?  What version?  Are you on a 64-bit 
> > machine?  Intel or AMD?
> > 
> > It seems to me that your uP does not know the assembler code in 
> > jidctflt.cxx:110.  As a workaround, you can put the 'else' branch in the 
> > 'then' too.
> 
> Thanks, workaround works. ptlib could be build with DEBUG=1.
> 
> opal could be build after --enable-debug too:
> [email protected] /home/nfs/extra/src/video/Ekiga/Ekiga-2008-12-29 $ ll 
> /usr/lib/lib*opa*
> -rwxr-xr-x 1 root root 73310760 31. Dez 13:44 /usr/lib/libopal_d_s.a
> lrwxrwxrwx 1 root root       22 31. Dez 13:44 /usr/lib/libopal_d.so -> 
> libopal_d.so.3.5-beta2
> -rwxr-xr-x 1 root root 51471518 31. Dez 13:44 /usr/lib/libopal_d.so.3.5-beta2
> 
> But it looks like ekiga itself is still insisting on a nondebugging version 
> of libopal :-( .

You need to use --enable-opal-debug as configure switch. (./configure
--help)
-- 
 _     Damien Sandras
(o-      
//\    Ekiga Softphone : http://www.ekiga.org/
v_/_   Be IP           : http://www.beip.be/
       FOSDEM          : http://www.fosdem.org/
       SIP Phone       : sip:[email protected]
                       

_______________________________________________
ekiga-list mailing list
[email protected]
http://mail.gnome.org/mailman/listinfo/ekiga-list
<Prev in Thread] Current Thread [Next in Thread>