[email protected]
[Top] [All Lists]

Re: [Ekiga-list] Ekiga cannot register with ekiga.net - Asterisk can

Subject: Re: [Ekiga-list] Ekiga cannot register with ekiga.net - Asterisk can
From: Damien Sandras
Date: Sat, 20 Dec 2008 17:20:29 +0100
Hi,

Le dimanche 14 dÃcembre 2008 Ã 20:21 +0100, Bent a Ãcrit :
> Hi
> 
> I have been unsubscribed to this list for a while so some
> advertisements may have posted regarding my problem. There is,
> however, not anything like it in the archives as far as I have been
> able to determine.
> 
> Anyway, my problem is stated in the subject line. Here are some details:
> 
> Asterisk runs on my gateway/firewall. My ekiga softphone (which is
> 2.0.12 - the latest issued by Gentoo) runs on a workstation behind the
> firewall. I use no proxy, but the firewall (another box running Gentoo
> Linux) has the SIP ALG enabled.
> 
> Asterisk registers fine with ekiga.net:
> 
> [email protected] ~ $ tshark -r ekiga-asterisk.trace
> Running as user "bent" and group "users".
>   1   0.000000  86.48.49.19 -> 86.64.162.35 SIP Request: OPTIONS sip:ekiga.net
>   2   0.024013 86.64.162.35 -> 86.48.49.19  SIP Status: 484 Address Incomplete

The Address Incomplete thing has just been fixed. It was a bug in the
Kamailio configuration.

>   3   0.093378  86.48.49.19 -> 86.64.162.35 SIP Request: REGISTER 
> sip:ekiga.net
>   4   0.116927 86.64.162.35 -> 86.48.49.19  SIP Status: 401
> Unauthorized    (0 bindings)
>   5   0.117983  86.48.49.19 -> 86.64.162.35 SIP Request: REGISTER 
> sip:ekiga.net
>   6   0.142500 86.64.162.35 -> 86.48.49.19  SIP Status: 200 OK    (1 bindings)
> [email protected] ~ $
> 
> whereas Ekiga the softphone doesn't:
> 
> [email protected] ~ $ tshark -r ekiga.trace
> Running as user "bent" and group "users".
>   1   0.000000  86.48.49.19 -> 86.64.162.35 SIP Request: REGISTER 
> sip:ekiga.net
>   2   0.009675  86.48.49.19 -> 86.64.162.35 SIP Request: SUBSCRIBE
> sip:[email protected]
>   3   0.023790 86.64.162.35 -> 86.48.49.19  SIP Status: 606 Not
> Acceptable    (0 bindings)
>   4   0.033924 86.64.162.35 -> 86.48.49.19  SIP Status: 202 OK
> [email protected] ~ $

Apparently, you are trying to register a private IP. Perhaps you have STUN 
enabled and the gateway replaces the public IP it sees by a private IP ?

> Several questions arise:
> 
> 1. Why do I get '484 Address Incomplete' when my Asterisk asks for options?
> 
> 2. Why does my Ekiga get a '606 Not Acceptable' when it tries to register?

See above.

> 3. Why is the subscribe accepted '202 OK'?

It is how it should be ;-)

-- 
 _     Damien Sandras
(o-      
//\    Ekiga Softphone : http://www.ekiga.org/
v_/_   Be IP           : http://www.beip.be/
       FOSDEM          : http://www.fosdem.org/
       SIP Phone       : sip:[email protected]
                       

_______________________________________________
ekiga-list mailing list
[email protected]
http://mail.gnome.org/mailman/listinfo/ekiga-list
<Prev in Thread] Current Thread [Next in Thread>