ekiga-list@gnome.org
[Top] [All Lists]

Re: [Ekiga-list] Compile Problem

Subject: Re: [Ekiga-list] Compile Problem
From: Brian
Date: Tue, 30 Dec 2008 20:46:49 +1000
Eugen,
Thanks this put me on the right track.
I can confirm that suse 11.1 is the problem.

In ekiga-3.0.1/lib/engine/ it still uses *.la files all these have been
removed in 11.1, in addition there is practically nothing in
/opt/gnome/lib. Most of those files have been moved to /usr/lib.
There were about 6 other files that were deleted altogether.
What a mess!
Anyway I got over all of them, and engine compiled ok.

Now I get to
/usr/lib/gcc/i586-suse-linux/4.3/../../../../i586-suse-linux/bin/ld:
cannot find -lresmgr
collect2: ld returned 1 exit status
make[3]: *** [ekiga] Error 1
make[3]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1'
make: *** [all] Error 2

Only to discover that suse dropped support for resmgr after 10.3.
It nolonger exists in 11.1. Suse now appears to use hal-resmgr.

Once I figured out what libs were required where, I coped, but I do not
understand how to proceed with this one.
Is it possible to remove the requirement to load resmgr?

Thanks,
Brian



Eugen Dedu wrote:
> Brian wrote:
>> Damien,
>>>> Can you provide a full log ?
>> Do you mean from a ekiga -d 4?
>>
>>>> I fear the V4L2 plugin is not installed, but only the 'deprecated' V4L2
>>>> plugin...
>>>>
>>
>> I agree, that is what it looks like and last time  I got out of the same
>> situation by installing the latest pwlib.
>>
>> I believe I have the latest installed, see below.
>>
>> Brian
>>
>>
>> pwlib-plugins-v4l2 - V4L2 support for pwlib
>>
>> This plugin enables 'video for linux' (version 2) support (e.g. for USB
>> cameras) for pwlib.
>> The level of support is unspecified
>>
>>
>> pwlib-plugins-v4l2-1.10.10-56.2 - V4L2 support for pwlib
> 
> This is the old plugin.
> 
> ekiga 3.0 compiles only with the latest versions of ptlib (previously
> caled pwlib) and opal: ptlib 2.4.2 (you have here 1.10.10) and opal 3.4.2.
> 
_______________________________________________
ekiga-list mailing list
ekiga-list@xxxxxxxxx
http://mail.gnome.org/mailman/listinfo/ekiga-list

<Prev in Thread] Current Thread [Next in Thread>