[email protected]
[Top] [All Lists]

Re: [Ekiga-list] Debian packages

Subject: Re: [Ekiga-list] Debian packages
From: Rick Pasotto
Date: Tue, 30 Dec 2008 15:13:39 -0500
On Tue, Dec 30, 2008 at 08:39:54PM +0100, Eugen Dedu wrote:
> Rick Pasotto wrote:
>> gnome-desktop-environment depends on ekiga (>= 2.0.12)
>>
>> Since 'aptitude install ekiga-snapshot' removes ekiga,
>> gnome-desktop-environment becomes BROKEN and the installation would
>> REMOVE 47 other packages.
>>
>> As far as I'm concerned, this means that ekiga-snapshot is NOT
>> installable.
>>
>> I think that the problem is that the version number for
>> ekiga-snapshot is 0-20081220-1 which is less than 2.0.12. Perhaps if
>> the version number were changed to something greater that 2.0.12 (eg,
>> 3-20081220-1) then the problem would go away.
>
> Hi,
>
> Increasing the version of ekiga-snapshot does not work.
>
> There are two solutions: - either stay as we are now.  Note that only
> gnome-desktop-environment  is removed (+old pwlwib/opal), not 47
> packages!! - or do not use ekiga-snapshot anymore, but ekiga (while
> ptlib and opal  are still named -snapshot, to avoid soname problems).
> Note that this  will not be intrusive or conflict with debian package,
> because the  version will be carefully chosen.
>
> What do people prefer??

Sorry to hear that changing the version number doesn't work. I'm not
really clear on exactly how the debian version number punctuation works.
Did you try using 3.0.0 or even 2.9? Perhaps the fact that the first
non-digit character is a '-' makes a difference.

The number of packages that depend on gnome-desktop-environment will
vary from system to system. On my machine the following 45 packages
would be removed:

arj{u} at-spi{u} cheese{u} dasher{u} dasher-data{u} dmz-cursor-theme{u}
eog{u} festival{u} festlex-cmu{u} festlex-poslex{u} festvox-kallpc16k{u}
file-roller{u} gcalctool{u} gconf-editor{u} gedit{u} gedit-common{u}
gnome-accessibility{u} gnome-accessibility-themes{u} gnome-core{u}
gnome-desktop-environment gnome-network-admin{u} gnome-orca{u}
gnome-power-manager{u} gnome-screensaver{u} gnome-themes{u} gok{u}
gstreamer0.10-tools{u} gucharmap{u} iceweasel-gnome-support{u}
libalut0{u} libavahi-ui0{u} libbrlapi0.5{u} libglew1.5{u}
libgnome-speech7{u} libgtk-vnc-1.0-0{u} libswfdec-0.6-90{u} libxevie1{u}
mousetweaks{u} python-brlapi{u} python-gtksourceview2{u}
python-pyatspi{u} rss-glx{u} swfdec-gnome{u} unace{u} vinagre{u} 

I guess I'll have to stay with 2.0.12.

-- 
"He who has never hoped can never despair." -- George Bernard Shaw
    Rick Pasotto    [email protected]    http://www.niof.net
_______________________________________________
ekiga-list mailing list
[email protected]
http://mail.gnome.org/mailman/listinfo/ekiga-list

<Prev in Thread] Current Thread [Next in Thread>