[email protected]
[Top] [All Lists]

Re: [Ekiga-list] Compile Problem

Subject: Re: [Ekiga-list] Compile Problem
From: Damien Sandras
Date: Sat, 27 Dec 2008 11:29:12 +0100
Hi,

Le samedi 27 dÃcembre 2008 Ã 11:30 +1000, Brian a Ãcrit :
> Hi,
> I am trying to compile ekiga 3.0.1 on a SUSE 11.1 system.
> I am not sure if there are two problems or they are related.
> 
> 1) My configure comes up with
> 
> configure:5040: gcc -E  conftest.c
> conftest.c:14:28: error: ac_nonexistent.h: No such file or directory
> configure:5046: $? = 1
> configure: failed program was:
> | /* confdefs.h.  */
> | #define PACKAGE_NAME "ekiga"
> | #define PACKAGE_TARNAME "ekiga"
> | #define PACKAGE_VERSION "3.0.1"
> | #define PACKAGE_STRING "ekiga 3.0.1"
> | #define PACKAGE_BUGREPORT
> "http://bugzilla.gnome.org/enter_bug.cgi?product=ekiga";
> | #define PACKAGE "ekiga"
> | #define VERSION "3.0.1"
> | #define MAJOR_VERSION 3
> | #define MINOR_VERSION 0
> | #define BUILD_TYPE ReleaseCode
> | #define BUILD_NUMBER 1
> | /* end confdefs.h.  */
> | #include <ac_nonexistent.h>
> configure:5079: result: gcc -E
> configure:5108: gcc -E  conftest.c
> configure:5114: $? = 0
> configure:5145: gcc -E  conftest.c
> conftest.c:14:28: error: ac_nonexistent.h: No such file or directory
> configure:5151: $? = 1
> configure: failed program was:
> | /* confdefs.h.  */
> | #define PACKAGE_NAME "ekiga"
> | #define PACKAGE_TARNAME "ekiga"
> | #define PACKAGE_VERSION "3.0.1"
> | #define PACKAGE_STRING "ekiga 3.0.1"
> | #define PACKAGE_BUGREPORT
> "http://bugzilla.gnome.org/enter_bug.cgi?product=ekiga";
> | #define PACKAGE "ekiga"
> | #define VERSION "3.0.1"
> | #define MAJOR_VERSION 3
> | #define MINOR_VERSION 0
> | #define BUILD_TYPE ReleaseCode
> | #define BUILD_NUMBER 1
> | /* end confdefs.h.  */


Not sure what it means.

> 2) The make fails with
> libtool: link: cannot find the library
> `/usr/lib/gcc/i586-suse-linux/4.3/../../../libsigc-2.0.la' or unhandled
> argument `/usr/lib/gcc/i586-suse-linux/4.3/../../../libsigc-2.0.la'
> make[6]: *** [liblocal-roster.la] Error 1
> make[6]: Leaving directory
> `/Documents/SOURCE/SUSE11/ekiga-3.0.1/lib/engine/presence/local-roster'
> make[5]: *** [all-recursive] Error 1
> make[5]: Leaving directory
> `/Documents/SOURCE/SUSE11/ekiga-3.0.1/lib/engine/presence'
> make[4]: *** [all-recursive] Error 1
> make[4]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1/lib/engine'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1/lib'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1/lib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/Documents/SOURCE/SUSE11/ekiga-3.0.1'
> make: *** [all] Error 2
> 

Do you have the devel versions of libsigc++2 installed ?

[...]

> I tried to use the supplied ekiga from suse 11.1 but it would not give
> me the option to use a V4L2 camera.

I think there is a separate plugin. That is weird it is not installed by
default, but go figure!

> Also I nolonger get the option to do a test during the config wizard.

It has been removed.
-- 
 _     Damien Sandras
(o-      
//\    Ekiga Softphone : http://www.ekiga.org/
v_/_   Be IP           : http://www.beip.be/
       FOSDEM          : http://www.fosdem.org/
       SIP Phone       : sip:[email protected]
                       

_______________________________________________
ekiga-list mailing list
[email protected]
http://mail.gnome.org/mailman/listinfo/ekiga-list
<Prev in Thread] Current Thread [Next in Thread>