[email protected]
[Top] [All Lists]

Bug#563659: marked as forwarded (dblatex: Fails with "filename" element

Subject: Bug#563659: marked as forwarded dblatex: Fails with "filename" elements containing anti-slashes
From: Debian Bug Tracking System
Date: Mon, 04 Jan 2010 21:21:13 +0000
Your message dated Mon, 04 Jan 2010 22:20:10 +0100
with message-id <[email protected]>
has caused the   report #563659,
regarding dblatex: Fails with "filename" elements containing anti-slashes
to be marked as having been forwarded to the upstream software
author(s) Benoit Guillon <[email protected]>

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email protected]

563659: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=563659
Debian Bug Tracking System
Contact [email protected] with problems
--- Begin Message ---
Subject: Re: Bug#563659: dblatex: Fails with "filename" elements containing anti-slashes
From: Andreas Hoenen
Date: Mon, 04 Jan 2010 22:20:10 +0100
Hi BenoÃt,

I want to inform you about Debian BTS dblatex report #563659 [1]:

SÃbastien Villemot <[email protected]> wrote:

> Package: dblatex
> Version: 0.2.12-2
> Severity: normal
> dblatex fails on the following DocBook example:
> ----------------<snippet>----------------
> <?xml version="1.0" encoding="utf-8" ?>
> <!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN" 
> "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd";>
> <book>
>   <chapter>
>     <title>Introduction</title>
>     <para><filename>c:\dynare\4.x.y</filename></para>
>   </chapter>
> </book>
> ----------------</snippet>---------------
> The problem occurs during TeX compilation, more precisely inside the 
> \nolinkurl{} generated from the "filename" element. Texlive 2009 does not 
> accept unescaped antislashes inside \nolinkurl{}, while Texlive 2007 did. The 
> solution is to espace anti-slashes with another anti-slash inside 
> \nolinkurl{}.
> This is an expected behaviour of Texlive 2009, see this thread:
> http://lists.debian.org/debian-tex-maint/2009/12/msg00661.html
> Note that this bug currently occurs only on unstable, since testing still 
> contains Texlive 2007.
> Also note that this affects at least one package relying on dblatex, see bug 
> #562321.

This looks familiar to me, the problem I mailed you recently is starting
to cause real trouble :-(

> From: Andreas Hoenen <[email protected]>
> To: Benoit Guillon <[email protected]>
> Subject: dblatex <-> TeX Live 2009: problem with \nolinkurl
> Date: Sun, 13 Dec 2009 15:26:46 +0100

Any ideas for a solution that works with old as well with new hyperref
versions?  Otherwise I would patch dblatex to support TeX Live 2009.

[1] http://bugs.debian.org/563659

Regards, Andreas
Andreas Hoenen <[email protected]>
GPG: 1024D/B888D2CE
     A4A6 E8B5 593A E89B 496B
     82F0 728D 8B7E B888 D2CE

--- End Message ---
<Prev in Thread] Current Thread [Next in Thread>
  • Bug#563659: marked as forwarded (dblatex: Fails with "filename" elements containing anti-slashes), Debian Bug Tracking System <=