[email protected]
[Top] [All Lists]

Bug#516521: marked as forwarded (psppire is fragile)

Subject: Bug#516521: marked as forwarded psppire is fragile
From: Debian Bug Tracking System
Date: Sun, 22 Feb 2009 02:12:03 +0000
Your message dated Sat, 21 Feb 2009 21:11:08 -0500
with message-id <[email protected]>
has caused the   report #516521,
regarding psppire is fragile
to be marked as having been forwarded to the upstream software
author(s) [email protected]

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email protected]
immediately.)


-- 
516521: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=516521
Debian Bug Tracking System
Contact [email protected] with problems
--- Begin Message ---
Subject: : psppire is fragile]
From: "James R. Van Zandt"
Date: Sat, 21 Feb 2009 21:11:08 -0500
I have not spent much time with psppire yet, but in fumbling around I
managed to crash it :-)

------- Start of forwarded message -------
From: "James R. Van Zandt" <[email protected]>
To: Debian Bug Tracking System <[email protected]>
Subject: psppire is fragile
Date: Sat, 21 Feb 2009 20:40:19 -0500

Package: pspp
Version: 0.6.1-2
Severity: normal


The GUI is pretty fragile:

Launch psppire.
Hit <down>.
Click on "Insert Case".  Get obscure error message:

** (psppire:14579): CRITICAL **: psppire_data_store_insert_new_case: assertion 
`val_cnt > 0' failed

Hit <right>.
Click on "Insert Variable".  Application crashes:

psppire: src/data/dictionary.c:590: dict_reorder_var: Assertion `new_index < 
d->var_cnt' failed.
Aborted (core dumped)

I suggest psppire should be more robust against the user doing dumb things.

        - Jim Van Zandt


- -- System Information:
Debian Release: 5.0
  APT prefers oldstable
  APT policy: (500, 'oldstable'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.25 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages pspp depends on:
ii  libatk1.0-0            1.22.0-1          The ATK accessibility toolkit
ii  libc6                  2.7-16            GNU C Library: Shared libraries
ii  libcairo2              1.6.4-6           The Cairo 2D vector graphics libra
ii  libglade2-0            1:2.6.3-1         library to load .glade files at ru
ii  libglib2.0-0           2.16.6-1          The GLib library of C routines
ii  libgsl0ldbl            1.12+dfsg-1       GNU Scientific Library (GSL) -- li
ii  libgtk2.0-0            2.12.11-3         The GTK+ graphical user interface 
ii  libice6                2:1.0.4-1         X11 Inter-Client Exchange library
ii  libncurses5            5.7+20081220-1    shared libraries for terminal hand
ii  libpango1.0-0          1.20.5-2          Layout and rendering of internatio
ii  libplot2c2             2.5-2+b1          The GNU plotutils libraries
ii  libpng12-0             1.2.27-2          PNG library - runtime
ii  libreadline5           5.2-3             GNU readline and history libraries
ii  libsm6                 2:1.0.3-2         X11 Session Management library
ii  libx11-6               2:1.1.5-2         X11 client-side library
ii  libxaw7                2:1.0.4-2         X11 Athena Widget library
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  libxml2                2.6.32.dfsg-5     GNOME XML library
ii  libxmu6                2:1.0.4-1         X11 miscellaneous utility library
ii  libxt6                 1:1.0.5-3         X11 toolkit intrinsics library
ii  zlib1g                 1:1.2.3.3.dfsg-12 compression library - runtime

pspp recommends no packages.

pspp suggests no packages.

- -- no debconf information
------- End of forwarded message -------


--- End Message ---
<Prev in Thread] Current Thread [Next in Thread>
  • Bug#516521: marked as forwarded (psppire is fragile), Debian Bug Tracking System <=