[email protected]
[Top] [All Lists]

Bug#512616: marked as forwarded ([openmpi] missing symbols?)

Subject: Bug#512616: marked as forwarded [openmpi] missing symbols?
From: Debian Bug Tracking System
Date: Fri, 23 Jan 2009 07:57:04 +0000
Your message dated Fri, 23 Jan 2009 08:54:27 +0100
with message-id <[email protected]>
has caused the   report #512616,
regarding [openmpi] missing symbols?
to be marked as having been forwarded to the upstream software
author(s) Dirk Eddelbuettel <[email protected]>

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact [email protected]
immediately.)


-- 
512616: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512616
Debian Bug Tracking System
Contact [email protected] with problems
--- Begin Message ---
Subject: Re: [Pkg-openmpi-maintainers] Bug#512616: [openmpi] missing symbols?
From: "Christophe Prud'homme"
Date: Fri, 23 Jan 2009 08:54:27 +0100
and here is the result of showme:link

mpiCC -showme:link -o t t.cpp -lHYPRE
                                                         /tmp
-pthread -o t t.cpp -lHYPRE -L/usr/lib/openmpi/lib -lmpi_cxx -lmpi
-lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl


On Fri, Jan 23, 2009 at 8:52 AM, Christophe Prud'homme
<[email protected]> wrote:
> Dirk
>
> here is a simple example, where I have a dummy code that I link with
> HYPRE from Debian. I compile with both mpiCC and g++ with -lmpi++
> -lmpi.
>
> t.cpp:
>
>  int main() {}
>
>
> g++ -o t t.cpp -lHYPRE -lmpi++ -lmpi
> /usr/bin/../lib/libHYPRE_mli-2.4.0.so: undefined reference to
> `MPI::Comm::Set_errhandler(MPI::Errhandler const&)'
> /usr/bin/../lib/libHYPRE_mli-2.4.0.so: undefined reference to
> `MPI::Win::Set_errhandler(MPI::Errhandler const&)'
> collect2: ld returned 1 exit status
>
>
> % mpiCC -o t t.cpp -lHYPRE
> /usr/bin/../lib/libHYPRE_mli-2.4.0.so: undefined reference to
> `MPI::Comm::Set_errhandler(MPI::Errhandler const&)'
> /usr/bin/../lib/libHYPRE_mli-2.4.0.so: undefined reference to
> `MPI::Win::Set_errhandler(MPI::Errhandler const&)'
>
> Best regards
> C.
>


--- End Message ---
<Prev in Thread] Current Thread [Next in Thread>
  • Bug#512616: marked as forwarded ([openmpi] missing symbols?), Debian Bug Tracking System <=