[email protected]
[Top] [All Lists]

Bug#295199: marked as forwarded (fig2dev bug with arrows)

Subject: Bug#295199: marked as forwarded fig2dev bug with arrows
From: Debian Bug Tracking System
Date: Sun, 23 Jul 2006 06:03:42 -0700
Your message dated Sun, 23 Jul 2006 14:58:18 +0200
with message-id <[email protected]>
has caused the Debian Bug report #295199,
regarding fig2dev bug with arrows
to be marked as having been forwarded to the upstream software
author(s) "Brian V. Smith" <[email protected]>.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Subject: Bug#295199: fig2dev bug with arrows
From: Roland Rosenfeld
Date: Sun, 23 Jul 2006 14:58:18 +0200
Hi Brian!

I received the attached bug report against the MetaPost driver, which
was upgraded in 3.2.5-alpha3:
        o Metapost (mp) driver now generates all Fig styles of arrowheads
          From Tim Braun

It seems this is not working completely correct, as you can see in the
attached example.  As far as I can see the new code creates an arrow
head, which looks like this:

                        | \
                        | /

instead of 

                        | \
                        | /

As far as I can see, the problem is also pertinent in 3.2.5-alpha7.


--- Begin Message ---
Subject: Bug#295199: fig2dev bug with arrows
From: Frank Homann
Date: Mon, 14 Feb 2005 12:10:43 +0100
Package: transfig
Version: 1:3.2.5-alpha5-2

We want to report a bug of transfig in the version 1:3.2.5-alpha5-2 (testing).
The 1:3.2.3.d-rel-2 version of transfig does not include this bug. It comes
out when converting arrows, drawn in xfig, to metapost. As attachment we send a
simple example, also for comparison of the two versions. In the 3.2.5 xfig
arrows are not built correctly any more.

In every case the result of this line works correctly:
fig2dev -L eps arrow.fig > arrow.eps

But these lines (MP-converting) only work correctly in version 3.2.3:
fig2dev -L mp arrow.fig > arrow.mmp
mpost arrow.mmp

The attachment contains a diff.txt, which maybe shows the problem concerning
the two different built mmp-files (depending on the transfig version).
The problem is obviously observable on these two files (or other.0.ps):
3.2.3/arrow.0 (ps file)
3.2.5/arrow.0 (ps file)

We are using Debian GNU/Linux, kernel 2.6.8-1-k7 and libc6 2.3.2.ds1-20.

Thank you.

Frank Homann
Computer Scientist

Darmstadt University of Technology
- IT Transfer Office (ITO) -
Hochschulstr. 10
64289 Darmstadt, Germany


Office in Department of Computer Science: Building S2|02, Room E223
Telephone: +49 (6151) 16-6216
eMail: [email protected]

--- End Message ---

--- End Message ---
<Prev in Thread] Current Thread [Next in Thread>
  • Bug#295199: marked as forwarded (fig2dev bug with arrows), Debian Bug Tracking System <=