[email protected]
[Top] [All Lists]

Bug#217217: marked as forwarded (vim-gtk: shows wrong translation, not r

Subject: Bug#217217: marked as forwarded vim-gtk: shows wrong translation, not respecting LC_MESSAGES
From: Debian Bug Tracking System
Date: Tue, 15 Mar 2005 09:04:32 -0800
Your message dated Tue, 15 Mar 2005 17:48:31 +0100
with message-id <[email protected]>
has caused the Debian Bug report #217217,
regarding vim-gtk: shows wrong translation, not respecting LC_MESSAGES
to be marked as having been forwarded to the upstream software
author(s) Anders Hermansen <[email protected]>.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at 217217-forwarded) by bugs.debian.org; 15 Mar 2005 16:48:46 +0000
>From [email protected] Tue Mar 15 08:48:45 2005
Return-path: <[email protected]>
Received: from lea.cs.unibo.it [] 
        by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1DBFDp-00068N-00; Tue, 15 Mar 2005 08:48:45 -0800
Received: from fistandantilus.takhisis.org (n32d211.cs.unibo.it 
        by lea.cs.unibo.it (Postfix) with ESMTP id 2ED528B452;
        Tue, 15 Mar 2005 17:48:44 +0100 (CET)
Received: by fistandantilus.takhisis.org (Postfix, from userid 3148)
        id 228C7274047; Tue, 15 Mar 2005 17:48:31 +0100 (CET)
Date: Tue, 15 Mar 2005 17:48:31 +0100
From: Stefano Zacchiroli <[email protected]>
To: Anders Hermansen <[email protected]>
Cc: [email protected], [email protected]
Subject: vim-gtk: shows wrong translation, not respecting LC_MESSAGES
Message-ID: <[email protected]>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: [email protected]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Hi Bram, I'm forwarding you a bug in vim-gtk regarding LC_MESSAGES.
Briefly: vim does not honor LC_MESSAGES environment variable.

Please find below the original text reported by Anders. I'm still able
to reproduce the bug with vim 6.3 freshly compiled from the tarball
available on the web.


> My locale settings is as follows (output by 'locale'):
> LANG=no_NO
> LC_CTYPE="no_NO"
> LC_TIME="no_NO"
> LC_PAPER="no_NO"
> LC_NAME="no_NO"
> According to this page
> http://www.gnu.org/manual/glibc-2.2.5/html_node/Locale-Categories.html#Locale%20Categories
> the definition of LC_MESSAGES is:
> "This category applies to selecting the language used in the user interface
> for message translation"
> When starting gvim with my locale setting I get Norwegian (no_NO) translation,
> although my LC_MESSAGES explicit says English (en_US)
> I believe gvim is using the wrong locale enviroment variable to determine
> the locale to use for translation.

Stefano Zacchiroli -*- Computer Science PhD student @ Uny Bologna, Italy
[email protected]{cs.unibo.it,debian.org,bononia.it} -%- http://www.bononia.it/zack/
If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. -!-

To UNSUBSCRIBE, email to [email protected]
with a subject of "unsubscribe". Trouble? Contact [email protected]

<Prev in Thread] Current Thread [Next in Thread>
  • Bug#217217: marked as forwarded (vim-gtk: shows wrong translation, not respecting LC_MESSAGES), Debian Bug Tracking System <=