[email protected]
[Top] [All Lists]

Bug#292884: marked as forwarded (auctex spins forever with font-lock ena

Subject: Bug#292884: marked as forwarded auctex spins forever with font-lock enabled
From: Debian Bug Tracking System
Date: Mon, 31 Jan 2005 02:03:16 -0800
Your message dated Mon, 31 Jan 2005 10:53:02 +0100
with message-id <[email protected]>
has caused the Debian Bug report #292884,
regarding auctex spins forever with font-lock enabled
to be marked as having been forwarded to the upstream software
author(s) [email protected]

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at 292884-forwarded) by bugs.debian.org; 31 Jan 2005 09:53:35 +0000
>From [email protected] Mon Jan 31 01:53:35 2005
Return-path: <[email protected]>
Received: from ppp-138-86.25-151.libero.it (hal.ts.infn.it) [] 
        by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1CvYFQ-0008UB-00; Mon, 31 Jan 2005 01:53:33 -0800
Received: from hal.ts.infn.it (Rino.DFT.INVALID [])
        by hal.ts.infn.it (Postfix) with ESMTP id CF3A74299;
        Mon, 31 Jan 2005 10:53:42 +0100 (CET)
Received: from salve by hal.ts.infn.it with local (masqmail 0.2.20) id
 1CvYEw-1hk-00; Mon, 31 Jan 2005 10:53:02 +0100
To: [email protected]
Cc: [email protected],
        Daniel Burrows <[email protected]>
Subject: [Daniel Burrows <[email protected]>] Bug#292884: auctex spins
 forever with font-lock enabled
From: "Davide G. M. Salvetti" <[email protected]>
X-Face: &6g,d%3hP0[qul^Z;FuwvIxNxPy2:}9K`7D?&[email protected]\S\AK\jI)J$yL:J>70*[c!k*
 f~gm03;w^G&m5Zc:z5sUq+eL2ZSj}[email protected])0L`FG34HLFs"*pmg,OEPk~V\L90ivCN=S}%*cUMw+E>!t-
 U{izN"hVM!$1`P\v~sRS:)^t_{py+"YcZ|2^z=AUz4"[email protected];'8dyarKA7)OPjihAGsMb
Organization: Quis ut Deus?
X-PGP-Fingerprint: D3B2 A3F5 E9EB BDE6 A245  AA4A 212B 306C 9396 865D
X-PGP-Affinity: Will accept encrypted messages for GNU Privacy Guard
X-Attribution: DGMS
X-Accept-Language: en, it, de, es
Date: Mon, 31 Jan 2005 10:53:02 +0100
Message-ID: <[email protected]>
Lines: 154
User-Agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.3 (gnu/linux)
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="=-=-="
Delivered-To: [email protected]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-13.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER,
        HAS_PACKAGE,VALID_BTS_CONTROL autolearn=ham 
X-CrossAssassin-Score: 2


tags 292884 + moreinfo unreproducible upstream
[Please ignore the two lines above and keep
[email protected] in cc if and when you reply.]

Hi developers,

this is a bug reported via the Debian bug tracking system.  I cannot
reproduce it on my system.

Does anybody have any clue about it?

Salve, | GNU PG (GPG) Key ID: 9396865D
Davide | <http://www.linux.it/~salve/>

Content-Type: message/rfc822
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

Return-Path: <[email protected]>
X-Original-To: [email protected]
Delivered-To: [email protected]
Received: by hal.ts.infn.it (Postfix, from userid 10)
        id E6E2942A5; Mon, 31 Jan 2005 10:25:04 +0100 (CET)
Received: from spohr.debian.org (spohr.debian.org [])
        by picard.linux.it (Postfix) with ESMTP id 40C836E088
        for <[email protected]>; Sun, 30 Jan 2005 22:23:17 +0100 (CET)
Received: from debbugs by spohr.debian.org with local (Exim 3.35 1 (Debian))
        id 1CvMSM-00037d-00; Sun, 30 Jan 2005 13:18:06 -0800
X-Loop: [email protected]
Subject: Bug#292884: auctex spins forever with font-lock enabled
Reply-To: Daniel Burrows <[email protected]>,
        [email protected]
Resent-From: Daniel Burrows <[email protected]>
Resent-To: [email protected]
Resent-Cc: [email protected] (Davide G. M. Salvetti)
Resent-Date: Sun, 30 Jan 2005 21:18:04 UTC
Resent-Message-ID: <[email protected]>
X-Debian-PR-Message: report 292884
X-Debian-PR-Package: auctex
Received: via spool by [email protected] id=B.11071194247094
          (code B ref -1); Sun, 30 Jan 2005 21:18:04 UTC
Received: (at submit) by bugs.debian.org; 30 Jan 2005 21:10:24 +0000
Received: from f05s05.cac.psu.edu (f05n05.cac.psu.edu) [] 
        by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
        id 1CvMKt-0001q3-00; Sun, 30 Jan 2005 13:10:24 -0800
Received: from jester.burrows.local (pool-207-68-120-192.alt.east.verizon.net 
        (authenticated bits=0)
        by f05n05.cac.psu.edu (8.13.2/8.13.2) with ESMTP id j0ULAKwP022406
        (version=TLSv1/SSLv3 cipher=RC4-MD5 bits=128 verify=NOT)
        for <[email protected]>; Sun, 30 Jan 2005 16:10:22 -0500
From: Daniel Burrows <[email protected]>
To: [email protected]
Date: Sun, 30 Jan 2005 16:10:10 -0500
User-Agent: KMail/1.7.2
MIME-Version: 1.0
Content-Type: multipart/signed;
Content-Transfer-Encoding: 7bit
Message-Id: <[email protected]>
Delivered-To: [email protected]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
        (1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
        autolearn=no version=2.60-bugs.debian.org_2005_01_02
Resent-Sender: Debian BTS <[email protected]>

Content-Type: text/plain;
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Package: auctex
Version: 11.54-4
Severity: normal

  A couple days ago, I was editing a large file when emacs went into what=20
appeared to be an infinite loop -- no display updates and it was eating 100=
of CPU.  I killed it and re-opened the file, only to have it hang again. =20
After a little experimentation, I determined that the following was=20
happening: if font-lock-mode is enabled, and some other unknown circumstanc=
holds, auctex goes nuts when I finish typing a tag.  For instance, I could=


  but when I type the "d", auctex hangs.  If I let it run long enough, an=20
autosave file is generated in which the "d" is present, and auctex can load=
and fontify it with no problems.

  I have no idea how to reduce this to a minimal test case, unfortunately. =
haven't seen it since I shut off font-lock-mode, but I can say that it=20
happens even if I move my .emacs out of the way (so my personal settings=20
aren't triggering whatever the problem is).


=2D- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.10-1-686
Locale: LANG=3Den_US, LC_CTYPE=3Den_US (charmap=3DISO-8859-1) (ignored: LC_=
ALL set=20
to en_US)

Versions of packages auctex depends on:
ii  debconf                       1.4.42     Debian configuration managemen=
ii  debianutils                   2.11.2     Miscellaneous utilities specif=
ii  emacs21                       21.3+1-8   The GNU Emacs editor
ii  make                          3.80-9     The GNU version of the "make"=

=2D- debconf information:
  auctex/doauto: Background
* auctex/default: true
  auctex/logfile: /tmp/update-auctex-elisp.XFhc0SH
  auctex/doautofg: File

/------------------- Daniel Burrows <[email protected]> -----------------=
|                             The Turtle Moves!                            =
\---------------- The Turtle Moves! -- http://www.lspace.org --------------=

Content-Type: application/pgp-signature

Version: GnuPG v1.2.5 (GNU/Linux)




To UNSUBSCRIBE, email to [email protected]
with a subject of "unsubscribe". Trouble? Contact [email protected]

<Prev in Thread] Current Thread [Next in Thread>
  • Bug#292884: marked as forwarded (auctex spins forever with font-lock enabled), Debian Bug Tracking System <=