cake-php@googlegroups.com
[Top] [All Lists]

Re: DebugKit

Subject: Re: DebugKit
From: Ed Propsner
Date: Fri, 30 Apr 2010 04:11:50 -0400
@AD7six

Nice, seems to have all cleared up. I'm still getting a fatal error on a few pages though: 

Fatal error: Call to a member function children() on a non-object in debug_kit\controllers\components\toolbar.php on line 563
 -> $tbody = $table->children('tbody');

The output shows on the very bottom of the page and with the way my pages are styled  it can be hard to read. I loaded a page that didn't have any content yet, just the default.ctp, and the output showed up where (it seems) $content_for_layout would normally display. It was styled with my CSS ... bullets, colors, headings, etc. ... I was rather impressed. What makes the diff ?? Is there a reason it don't display that way on all the pages ? 

- Ed  


On Fri, Apr 30, 2010 at 3:46 AM, Ed Propsner <crotchfrog@xxxxxxxxx> wrote:
Ah ha, good thing at least one of us knows what the heck they are doing ... now that you mention it I've had the same version since Cake 1.2x, I just haven't been using it until recently. Let me take another at it and I'll get back to ya' :)

- Ed 


On Fri, Apr 30, 2010 at 3:41 AM, AD7six <andydawson76@xxxxxxxxx> wrote:


On Apr 29, 11:24 pm, Ed Propsner <crotchf...@xxxxxxxxx> wrote:
> Could anyone tell me where I went wrong with debugkit? The installation was
> straightforward enough that it seemed impossible to screw up.
>
> Anyhow, it returns all the data that would be expected but it also returns a
> ton of warnings, ie:
>
> *Warning*: Missing argument 2 for DebugKitDebugger::_output(),
>
> It repeats this error for args 3, 4, 5, etc. then starts displaying notices,
> ie:
>
> *Notice*: Undefined variable: kontext
>
> It repeats this process several times over.
>
> Also, I can only get it work if I have debug to set on 2,
> debug 1 returns all the errors I just described and nothing else.
>
> Did I screw something up in Cake to make debugkit freak out or am
> I botching the installation of debugkit?

You've probably managed to install the 1.2 branch/version of debug kit
and are running 1.3. Check which branch you've pulled from

http://github.com/cakephp/debug_kit/blob/master/vendors/debug_kit_debugger.php#L338

AD

Check out the new CakePHP Questions site http://cakeqs.org and help others with their CakePHP related questions.

You received this message because you are subscribed to the Google Groups "CakePHP" group.
To post to this group, send email to cake-php@xxxxxxxxxxxxxxxx
To unsubscribe from this group, send email to
cake-php+unsubscribe@xxxxxxxxxxxxxxxx For more options, visit this group at http://groups.google.com/group/cake-php?hl=en


Check out the new CakePHP Questions site http://cakeqs.org and help others with their CakePHP related questions.
 
You received this message because you are subscribed to the Google Groups "CakePHP" group.
To post to this group, send email to cake-php@xxxxxxxxxxxxxxxx
To unsubscribe from this group, send email to
cake-php+unsubscribe@xxxxxxxxxxxxxxxx For more options, visit this group at http://groups.google.com/group/cake-php?hl=en
<Prev in Thread] Current Thread [Next in Thread>